mariadb_repo_setup for MariaDB Community Server 10.5

The mariadb_repo_setup script configures APT/YUM/ZYpp to install software from the MariaDB Community Server repository on supported Linux operating systems.

Note

To configure APT/YUM/ZYpp to install software from the MariaDB Enterprise Server repository, see mariadb_es_repo_setup instead.

Installation

The mariadb_repo_setup script is available for download from MariaDB Corporation:

Additional information on its use is available in the Deployment Guide.

mariadb_repo_setup Options for MariaDB Community Server 10.5

Option

Description

--help

Display this help and exit.

--mariadb-maxscale-version

Override the default MariaDB MaxScale version. By default, the script will use 'latest'.

--mariadb-server-version

Override the default MariaDB Server version. By default, the script will use 'mariadb-10.6'.

--os-type

Override detection of OS type. Acceptable values include 'debian', 'ubuntu', 'rhel', and 'sles'.

--os-version

Override detection of OS version. Acceptable values depend on the OS type you specify.

--skip-check-installed

Skip tests for required prerequisites for this script.

--skip-key-import

Skip importing GPG signing keys.

--skip-maxscale

Skip the 'MaxScale' repository.

--skip-server

Skip the 'MariaDB Server' repository.

--skip-tools

Skip the 'Tools' repository.

--version

Output the script version and exit.

--write-to-stdout

Write output to stdout instead of to the OS's repository configuration. This will also skip importing GPG keys and updating the package cache on platforms where that behavior exists.

To see options supported in other versions, see "mariadb_repo_setup Options by MariaDB Server Version".