--require-secure-transport

This is a command-line option for the mariadbd & mysqld commands.

In 10.6 ES, 10.6 CS, 10.5 ES, 10.5 CS, 10.4 ES:

When this option is enabled, connections attempted using insecure transport will be rejected. Secure transports are SSL/TLS, Unix sockets or named pipes.

In 10.4 CS, 10.3 ES, 10.3 CS, 10.2 ES, 10.2 CS:

Not present

See also: mariadbd & mysqld for MariaDB Enterprise Server 10.6, in 10.6 CS, in 10.5 ES, in 10.5 CS, in 10.4 ES, in 10.4 CS, in 10.3 ES, in 10.3 CS, in 10.2 ES, and in 10.2 CS

CHANGE HISTORY

Release Series

History

10.6 Enterprise

  • Present starting in MariaDB Enterprise Server 10.6.4-1.

10.6 Community

  • Present starting in MariaDB Community Server 10.6.0.

10.5 Enterprise

  • Added in MariaDB Enterprise Server 10.5.3-1.

10.5 Community

  • Added in MariaDB Community Server 10.5.2.

10.4 Enterprise

  • Added in MariaDB Enterprise Server 10.4.13-7.

10.4 Community

  • Not present.

10.3 Enterprise

  • Not present.

10.3 Community

  • Not present.

10.2 Enterprise

  • Not present.

10.2 Community

  • Not present.