--mariadb-maxscale-version

Overview

Override the default MariaDB MaxScale version. By default, the script will use 'latest'.

See also: mariadb_es_repo_setup for MariaDB Enterprise Server

USAGE

A specific release series of MariaDB MaxScale can be specified using the --mariadb-maxscale-version flag:

$ sudo ./mariadb_es_repo_setup --token="CUSTOMER_DOWNLOAD_TOKEN" --apply \
      --mariadb-maxscale-version="6"

A specific release of MariaDB Enterprise Server can also be specified using the --mariadb-maxscale-version flag:

$ sudo ./mariadb_es_repo_setup --token="CUSTOMER_DOWNLOAD_TOKEN" --apply \
      --mariadb-maxscale-version="6.4.5"

DETAILS

The --mariadb-maxscale-version flag is used to configure a system to install a specific release series or a specific release of MariaDB MaxScale from the MariaDB Enterprise Repository.

PARAMETERS

The --mariadb-maxscale-version flag expects a specific release series or a specific release of MariaDB MaxScale as its argument.

The supported release series and releases are shown below.

MaxScale Release Series

  • 22.08 or latest (Default)

  • 6

  • 2.5

  • 2.4

MaxScale 22.08 Releases

  • 22.08.4

  • 22.08.3

  • 22.08.2

  • 22.08.1

MaxScale 6 Releases

  • 6.4.5

  • 6.4.4

  • 6.4.3

  • 6.4.2

  • 6.4.1

  • 6.4.0

  • 6.3.1

  • 6.3.0

  • 6.2.4

  • 6.2.3

  • 6.2.2

  • 6.2.1

  • 6.2.0

  • 6.1.1

MaxScale 2.5 Releases

  • 2.5.24

  • 2.5.23

  • 2.5.22

  • 2.5.21

  • 2.5.20

  • 2.5.19

  • 2.5.13

  • 2.5.12

  • 2.5.11

  • 2.5.10

  • 2.5.9

  • 2.5.8

  • 2.5.7

  • 2.5.6

  • 2.5.5

  • 2.5.4

  • 2.5.3

  • 2.5.2

  • 2.5.1

MaxScale 2.4 Releases

  • 2.4.17

  • 2.4.16

  • 2.4.15

  • 2.4.14

  • 2.4.13

  • 2.4.12

  • 2.4.11

  • 2.4.10

  • 2.4.9

  • 2.4.8

  • 2.4.7

  • 2.4.6

  • 2.4.5

  • 2.4.4

  • 2.4.3

  • 2.4.2

  • 2.4.1