On a fresh CentOS 5.x/6.x 32bit or 64bit install, mysql 5.0.xx is installed. To install MariaDB 5.2.x rpms, mysql-lib needs to be removed for MariaDB-server to be installed.

But removing mysql-lib via yum remove, removes postfix.

If later you need to install postfix via yum it still requires mysql-lib, but installing mysql-lib installs mysql 5.0.x server again.

yum install postfix
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base: mirror.averse.net
 * extras: mirror.averse.net
 * rpmforge: apt.sw.be
 * updates: mirror.averse.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postfix.x86_64 2:2.6.6-2.1.el6_0 set to be updated
--> Processing Dependency: mysql-libs for package: 2:postfix-2.6.6-2.1.el6_0.x86_64
--> Finished Dependency Resolution
Error: Package: 2:postfix-2.6.6-2.1.el6_0.x86_64 (updates)
           Requires: mysql-libs
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Anyway to properly resolve this ? with MariaDB 5.2/5.3.x version of mysql-lib ??

Answer Answered by sergii in this comment.

This is CentOS 6 specific issue. And it is fixed in MariaDB 5.5 branch.

Comments

Comments loading...