Obsessed with dynamic columns, I'm considering moving our whole install from MySQL 5.5/MyISAM (just upgraded from 5.1 a few months back when this would have been a no-brainer) over/down to MariaDB/MyISAM 5.3.

I am wondering if there is any official word on engine/table compatibility and what I would have to undo for this move.

Answer Answered by byte in this comment.

Hi!

Are you using InnoDB? The file formats in theory should be the same (MySQL 5.5's InnoDB format with XtraDB in MariaDB 5.3). But your mileage may vary -- we haven't tested such downgrades.

If its just MyISAM, I think you shouldn't have too many issues.

Why not do this on a test server and let us know the results?

Comments

Comments loading...