Mariadb 10 installation on rhel 6.2 failing asking dependancy

Hi Team,

I did installation using yum last time and it got success with same configuration, but this time i am having dependency rpm problem, just wanted to looking if i can get all dependency rpm list in Mariadb installation document so it will be standard process to check the rpm and start the installation.

Requires: libssl.so.10(libssl.so.10)(64bit)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Requires: libz.so.1(ZLIB_1.2.0)(64bit)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

All yum logs,

yum install MariaDB-server MariaDB-client
Loaded plugins: refresh-packagekit, security
mariadb                                                                                                                                                  | 2.9 kB     00:00
mariadb/primary_db                                                                                                                                       |  22 kB     00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: MariaDB-common for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
---> Package MariaDB-server.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: galera for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
---> Package mysql.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
---> Package mysql-server.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
---> Package MariaDB-common.x86_64 0:10.4.0-1.el6 will be installed
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-common-10.4.0-1.el6.x86_64
--> Processing Dependency: MariaDB-compat for package: MariaDB-common-10.4.0-1.el6.x86_64
---> Package MariaDB-server.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
---> Package galera.x86_64 0:25.3.24-1.rhel6.el6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: galera-25.3.24-1.rhel6.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: galera-25.3.24-1.rhel6.el6.x86_64
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
---> Package MariaDB-common.x86_64 0:10.4.0-1.el6 will be installed
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-common-10.4.0-1.el6.x86_64
---> Package MariaDB-compat.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-compat-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-compat-10.4.0-1.el6.x86_64
---> Package MariaDB-server.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-server-10.4.0-1.el6.x86_64
---> Package galera.x86_64 0:25.3.24-1.rhel6.el6 will be installed
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: galera-25.3.24-1.rhel6.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: galera-25.3.24-1.rhel6.el6.x86_64
---> Package mysql-libs.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
--> Finished Dependency Resolution
Error: Package: MariaDB-server-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: MariaDB-compat-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: MariaDB-client-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: galera-25.3.24-1.rhel6.el6.x86_64 (mariadb)
           Requires: libssl.so.10(libssl.so.10)(64bit)
Error: Package: MariaDB-common-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: MariaDB-compat-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: MariaDB-server-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: MariaDB-client-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: MariaDB-client-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libz.so.1(ZLIB_1.2.0)(64bit)
Error: Package: MariaDB-server-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libz.so.1(ZLIB_1.2.0)(64bit)
Error: Package: MariaDB-client-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
Error: Package: MariaDB-server-10.4.0-1.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
Error: Package: galera-25.3.24-1.rhel6.el6.x86_64 (mariadb)
           Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Answer Answered by Gajendra Bhende in this comment.

using below method , able to successfully install mariadb,

[root@mariadb01 yum.repos.d]# yum install libssl.so.10
Loaded plugins: refresh-packagekit, security
ol6_UEK_latest                                                                                                                                           | 1.2 kB     00:00
ol6_UEK_latest/primary                                                                                                                                   |  39 MB     00:13
ol6_UEK_latest                                                                                                                                                          820/820
ol6_latest                                                                                                                                               | 1.4 kB     00:00
ol6_latest/primary                                                                                                                                       | 7.1 MB     00:00
ol6_latest                                                                                                                                                          11291/11291
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openssl.i686 0:1.0.1e-57.0.6.el6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libz.so.1 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.47.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.47.el6 for package: glibc-common-2.12-1.47.el6.x86_64
---> Package glibc.i686 0:2.12-1.212.0.1.el6 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.212.0.1.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.212.0.1.el6.i686
---> Package glibc.x86_64 0:2.12-1.212.0.1.el6 will be an update
---> Package krb5-libs.x86_64 0:1.9-22.el6 will be updated
--> Processing Dependency: libkadm5clnt_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5(kdb5_5_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: krb5-libs = 1.9-22.el6 for package: krb5-workstation-1.9-22.el6.x86_64
---> Package krb5-libs.i686 0:1.10.3-65.el6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-65.el6.i686
---> Package krb5-libs.x86_64 0:1.10.3-65.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-11.el6 will be updated
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-libs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: libss-1.41.12-11.el6.x86_64
---> Package libcom_err.i686 0:1.42.8-1.0.3.el6 will be installed
---> Package libcom_err.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package glibc-common.x86_64 0:2.12-1.47.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.212.0.1.el6 will be an update
--> Processing Dependency: tzdata >= 2015g-4 for package: glibc-common-2.12-1.212.0.1.el6.x86_64
---> Package keyutils-libs.x86_64 0:1.4-3.el6 will be updated
--> Processing Dependency: keyutils-libs = 1.4-3.el6 for package: keyutils-1.4-3.el6.x86_64
---> Package keyutils-libs.i686 0:1.4-5.0.1.el6 will be installed
---> Package keyutils-libs.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package krb5-workstation.x86_64 0:1.9-22.el6 will be updated
---> Package krb5-workstation.x86_64 0:1.10.3-65.el6 will be an update
---> Package libselinux.x86_64 0:2.0.94-5.2.el6 will be updated
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-utils-2.0.94-5.2.el6.x86_64
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-python-2.0.94-5.2.el6.x86_64
---> Package libselinux.i686 0:2.0.94-7.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-7.el6 will be an update
---> Package libss.x86_64 0:1.41.12-11.el6 will be updated
---> Package libss.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.0.1.el6_8 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-23.3.0.1.el6_8 will be an update
--> Running transaction check
---> Package keyutils.x86_64 0:1.4-3.el6 will be updated
---> Package keyutils.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package libselinux-python.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-python.x86_64 0:2.0.94-7.el6 will be an update
---> Package libselinux-utils.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-utils.x86_64 0:2.0.94-7.el6 will be an update
---> Package tzdata.noarch 0:2011l-4.el6 will be updated
---> Package tzdata.noarch 0:2018g-1.el6 will be an update
--> Processing Conflict: krb5-libs-1.10.3-65.el6.x86_64 conflicts libsmbclient < 3.5.10-124
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libsmbclient.x86_64 0:3.5.10-114.el6 will be updated
---> Package libsmbclient.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind-clients = 3.6.23-51.0.1.el6 for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtalloc.so.2(TALLOC_2.0.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.1)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.9)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.5)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package libtalloc.x86_64 0:2.0.1-1.1.el6 will be updated
---> Package libtalloc.x86_64 0:2.1.5-1.el6_7 will be an update
---> Package libtdb.x86_64 0:1.2.1-3.el6 will be updated
---> Package libtdb.x86_64 0:1.3.8-3.el6_8.2 will be an update
---> Package libtevent.x86_64 0:0.9.8-8.el6 will be updated
---> Package libtevent.x86_64 0:0.9.26-2.el6_7 will be an update
---> Package samba-winbind-clients.x86_64 0:3.5.10-114.el6 will be updated
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-client-3.5.10-114.el6.x86_64
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-common-3.5.10-114.el6.x86_64
---> Package samba-winbind-clients.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind = 3.6.23-51.0.1.el6 for package: samba-winbind-clients-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package samba-client.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-client.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-common.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-common.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-winbind.x86_64 0:3.6.23-51.0.1.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: openssl-1.0.1e-57.0.6.el6.i686 != openssl-1.0.0-20.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@mariadb01 yum.repos.d]# yum install libcrypto.so.10
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openssl.i686 0:1.0.1e-57.0.6.el6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libz.so.1 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.47.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.47.el6 for package: glibc-common-2.12-1.47.el6.x86_64
---> Package glibc.i686 0:2.12-1.212.0.1.el6 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.212.0.1.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.212.0.1.el6.i686
---> Package glibc.x86_64 0:2.12-1.212.0.1.el6 will be an update
---> Package krb5-libs.x86_64 0:1.9-22.el6 will be updated
--> Processing Dependency: libkadm5clnt_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5(kdb5_5_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: krb5-libs = 1.9-22.el6 for package: krb5-workstation-1.9-22.el6.x86_64
---> Package krb5-libs.i686 0:1.10.3-65.el6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-65.el6.i686
---> Package krb5-libs.x86_64 0:1.10.3-65.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-11.el6 will be updated
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-libs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: libss-1.41.12-11.el6.x86_64
---> Package libcom_err.i686 0:1.42.8-1.0.3.el6 will be installed
---> Package libcom_err.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package glibc-common.x86_64 0:2.12-1.47.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.212.0.1.el6 will be an update
--> Processing Dependency: tzdata >= 2015g-4 for package: glibc-common-2.12-1.212.0.1.el6.x86_64
---> Package keyutils-libs.x86_64 0:1.4-3.el6 will be updated
--> Processing Dependency: keyutils-libs = 1.4-3.el6 for package: keyutils-1.4-3.el6.x86_64
---> Package keyutils-libs.i686 0:1.4-5.0.1.el6 will be installed
---> Package keyutils-libs.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package krb5-workstation.x86_64 0:1.9-22.el6 will be updated
---> Package krb5-workstation.x86_64 0:1.10.3-65.el6 will be an update
---> Package libselinux.x86_64 0:2.0.94-5.2.el6 will be updated
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-utils-2.0.94-5.2.el6.x86_64
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-python-2.0.94-5.2.el6.x86_64
---> Package libselinux.i686 0:2.0.94-7.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-7.el6 will be an update
---> Package libss.x86_64 0:1.41.12-11.el6 will be updated
---> Package libss.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.0.1.el6_8 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-23.3.0.1.el6_8 will be an update
--> Running transaction check
---> Package keyutils.x86_64 0:1.4-3.el6 will be updated
---> Package keyutils.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package libselinux-python.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-python.x86_64 0:2.0.94-7.el6 will be an update
---> Package libselinux-utils.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-utils.x86_64 0:2.0.94-7.el6 will be an update
---> Package tzdata.noarch 0:2011l-4.el6 will be updated
---> Package tzdata.noarch 0:2018g-1.el6 will be an update
--> Processing Conflict: krb5-libs-1.10.3-65.el6.x86_64 conflicts libsmbclient < 3.5.10-124
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libsmbclient.x86_64 0:3.5.10-114.el6 will be updated
---> Package libsmbclient.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind-clients = 3.6.23-51.0.1.el6 for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtalloc.so.2(TALLOC_2.0.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.1)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.9)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.5)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package libtalloc.x86_64 0:2.0.1-1.1.el6 will be updated
---> Package libtalloc.x86_64 0:2.1.5-1.el6_7 will be an update
---> Package libtdb.x86_64 0:1.2.1-3.el6 will be updated
---> Package libtdb.x86_64 0:1.3.8-3.el6_8.2 will be an update
---> Package libtevent.x86_64 0:0.9.8-8.el6 will be updated
---> Package libtevent.x86_64 0:0.9.26-2.el6_7 will be an update
---> Package samba-winbind-clients.x86_64 0:3.5.10-114.el6 will be updated
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-client-3.5.10-114.el6.x86_64
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-common-3.5.10-114.el6.x86_64
---> Package samba-winbind-clients.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind = 3.6.23-51.0.1.el6 for package: samba-winbind-clients-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package samba-client.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-client.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-common.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-common.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-winbind.x86_64 0:3.6.23-51.0.1.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: openssl-1.0.1e-57.0.6.el6.i686 != openssl-1.0.0-20.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@mariadb01 yum.repos.d]# yum install libz.so.1
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: zlib-1.2.3-29.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: zlib-1.2.3-29.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: zlib-1.2.3-29.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: zlib-1.2.3-29.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: zlib-1.2.3-29.el6.i686
--> Processing Dependency: libc.so.6 for package: zlib-1.2.3-29.el6.i686
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.47.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.47.el6 for package: glibc-common-2.12-1.47.el6.x86_64
---> Package glibc.i686 0:2.12-1.212.0.1.el6 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.212.0.1.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.212.0.1.el6.i686
---> Package glibc.x86_64 0:2.12-1.212.0.1.el6 will be an update
--> Running transaction check
---> Package glibc-common.x86_64 0:2.12-1.47.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.212.0.1.el6 will be an update
--> Processing Dependency: tzdata >= 2015g-4 for package: glibc-common-2.12-1.212.0.1.el6.x86_64
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.0.1.el6_8 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-23.3.0.1.el6_8 will be an update
--> Running transaction check
---> Package tzdata.noarch 0:2011l-4.el6 will be updated
---> Package tzdata.noarch 0:2018g-1.el6 will be an update
--> Finished Dependency Resolution
Error: Protected multilib versions: zlib-1.2.3-29.el6.i686 != zlib-1.2.3-27.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@mariadb01 yum.repos.d]# yum install libcrypto.so.10
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openssl.i686 0:1.0.1e-57.0.6.el6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libz.so.1 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.1e-57.0.6.el6.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.1e-57.0.6.el6.i686
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.47.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.47.el6 for package: glibc-common-2.12-1.47.el6.x86_64
---> Package glibc.i686 0:2.12-1.212.0.1.el6 will be installed
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.212.0.1.el6.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.212.0.1.el6.i686
---> Package glibc.x86_64 0:2.12-1.212.0.1.el6 will be an update
---> Package krb5-libs.x86_64 0:1.9-22.el6 will be updated
--> Processing Dependency: libkadm5clnt_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5clnt_mit.so.8(kadm5clnt_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkadm5srv_mit.so.8(kadm5srv_mit_8_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5()(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: libkdb5.so.5(kdb5_5_MIT)(64bit) for package: krb5-workstation-1.9-22.el6.x86_64
--> Processing Dependency: krb5-libs = 1.9-22.el6 for package: krb5-workstation-1.9-22.el6.x86_64
---> Package krb5-libs.i686 0:1.10.3-65.el6 will be installed
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-65.el6.i686
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-65.el6.i686
---> Package krb5-libs.x86_64 0:1.10.3-65.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-11.el6 will be updated
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: e2fsprogs-libs-1.41.12-11.el6.x86_64
--> Processing Dependency: libcom_err = 1.41.12-11.el6 for package: libss-1.41.12-11.el6.x86_64
---> Package libcom_err.i686 0:1.42.8-1.0.3.el6 will be installed
---> Package libcom_err.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-11.el6 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package glibc-common.x86_64 0:2.12-1.47.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.212.0.1.el6 will be an update
--> Processing Dependency: tzdata >= 2015g-4 for package: glibc-common-2.12-1.212.0.1.el6.x86_64
---> Package keyutils-libs.x86_64 0:1.4-3.el6 will be updated
--> Processing Dependency: keyutils-libs = 1.4-3.el6 for package: keyutils-1.4-3.el6.x86_64
---> Package keyutils-libs.i686 0:1.4-5.0.1.el6 will be installed
---> Package keyutils-libs.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package krb5-workstation.x86_64 0:1.9-22.el6 will be updated
---> Package krb5-workstation.x86_64 0:1.10.3-65.el6 will be an update
---> Package libselinux.x86_64 0:2.0.94-5.2.el6 will be updated
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-utils-2.0.94-5.2.el6.x86_64
--> Processing Dependency: libselinux = 2.0.94-5.2.el6 for package: libselinux-python-2.0.94-5.2.el6.x86_64
---> Package libselinux.i686 0:2.0.94-7.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-7.el6 will be an update
---> Package libss.x86_64 0:1.41.12-11.el6 will be updated
---> Package libss.x86_64 0:1.42.8-1.0.3.el6 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.0.1.el6_8 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-23.3.0.1.el6_8 will be an update
--> Running transaction check
---> Package keyutils.x86_64 0:1.4-3.el6 will be updated
---> Package keyutils.x86_64 0:1.4-5.0.1.el6 will be an update
---> Package libselinux-python.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-python.x86_64 0:2.0.94-7.el6 will be an update
---> Package libselinux-utils.x86_64 0:2.0.94-5.2.el6 will be updated
---> Package libselinux-utils.x86_64 0:2.0.94-7.el6 will be an update
---> Package tzdata.noarch 0:2011l-4.el6 will be updated
---> Package tzdata.noarch 0:2018g-1.el6 will be an update
--> Processing Conflict: krb5-libs-1.10.3-65.el6.x86_64 conflicts libsmbclient < 3.5.10-124
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libsmbclient.x86_64 0:3.5.10-114.el6 will be updated
---> Package libsmbclient.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind-clients = 3.6.23-51.0.1.el6 for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtalloc.so.2(TALLOC_2.0.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.1)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtevent.so.0(TEVENT_0.9.9)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.2)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Processing Dependency: libtdb.so.1(TDB_1.2.5)(64bit) for package: libsmbclient-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package libtalloc.x86_64 0:2.0.1-1.1.el6 will be updated
---> Package libtalloc.x86_64 0:2.1.5-1.el6_7 will be an update
---> Package libtdb.x86_64 0:1.2.1-3.el6 will be updated
---> Package libtdb.x86_64 0:1.3.8-3.el6_8.2 will be an update
---> Package libtevent.x86_64 0:0.9.8-8.el6 will be updated
---> Package libtevent.x86_64 0:0.9.26-2.el6_7 will be an update
---> Package samba-winbind-clients.x86_64 0:3.5.10-114.el6 will be updated
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-client-3.5.10-114.el6.x86_64
--> Processing Dependency: samba-winbind-clients = 3.5.10-114.el6 for package: samba-common-3.5.10-114.el6.x86_64
---> Package samba-winbind-clients.x86_64 0:3.6.23-51.0.1.el6 will be an update
--> Processing Dependency: samba-winbind = 3.6.23-51.0.1.el6 for package: samba-winbind-clients-3.6.23-51.0.1.el6.x86_64
--> Running transaction check
---> Package samba-client.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-client.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-common.x86_64 0:3.5.10-114.el6 will be updated
---> Package samba-common.x86_64 0:3.6.23-51.0.1.el6 will be an update
---> Package samba-winbind.x86_64 0:3.6.23-51.0.1.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: openssl-1.0.1e-57.0.6.el6.i686 != openssl-1.0.0-20.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@mariadb01 yum.repos.d]# yum install MariaDB-server MariaDB-client
Loaded plugins: refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: libz.so.1(ZLIB_1.2.0)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: MariaDB-common for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.1)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libssl.so.10(libssl.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
--> Processing Dependency: libcrypto.so.10(libcrypto.so.10)(64bit) for package: MariaDB-client-10.4.0-1.el6.x86_64
---> Package MariaDB-server.x86_64 0:10.4.0-1.el6 will be obsoleting
--> Processing Dependency: galera for package: MariaDB-server-10.4.0-1.el6.x86_64
---> Package mysql.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
---> Package mysql-server.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
--> Running transaction check
---> Package MariaDB-common.x86_64 0:10.4.0-1.el6 will be installed
--> Processing Dependency: MariaDB-compat for package: MariaDB-common-10.4.0-1.el6.x86_64
---> Package galera.x86_64 0:25.3.24-1.rhel6.el6 will be installed
---> Package openssl.x86_64 0:1.0.0-20.el6 will be updated
---> Package openssl.x86_64 0:1.0.1e-57.0.6.el6 will be an update
---> Package zlib.x86_64 0:1.2.3-27.el6 will be updated
---> Package zlib.x86_64 0:1.2.3-29.el6 will be an update
--> Running transaction check
---> Package MariaDB-compat.x86_64 0:10.4.0-1.el6 will be obsoleting
---> Package mysql-libs.x86_64 0:5.1.52-1.el6_0.1 will be obsoleted
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================================================================================================================
 Package                                     Arch                                Version                                          Repository                               Size
================================================================================================================================================================================
Installing:
 MariaDB-client                              x86_64                              10.4.0-1.el6                                     mariadb                                  57 M
     replacing  mysql.x86_64 5.1.52-1.el6_0.1
 MariaDB-compat                              x86_64                              10.4.0-1.el6                                     mariadb                                 4.0 M
     replacing  mysql-libs.x86_64 5.1.52-1.el6_0.1
 MariaDB-server                              x86_64                              10.4.0-1.el6                                     mariadb                                 129 M
     replacing  mysql-server.x86_64 5.1.52-1.el6_0.1
Installing for dependencies:
 MariaDB-common                              x86_64                              10.4.0-1.el6                                     mariadb                                 155 k
 galera                                      x86_64                              25.3.24-1.rhel6.el6                              mariadb                                 8.8 M
Updating for dependencies:
 openssl                                     x86_64                              1.0.1e-57.0.6.el6                                ol6_latest                              1.5 M
 zlib                                        x86_64                              1.2.3-29.el6                                     ol6_latest                               72 k

Transaction Summary
================================================================================================================================================================================
Install       5 Package(s)
Upgrade       2 Package(s)

Total download size: 200 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): MariaDB-10.4.0-centos6-x86_64-client.rpm                                                                                                          |  57 MB     00:04
(2/7): MariaDB-10.4.0-centos6-x86_64-common.rpm                                                                                                          | 155 kB     00:00
(3/7): MariaDB-10.4.0-centos6-x86_64-compat.rpm                                                                                                          | 4.0 MB     00:00
(4/7): MariaDB-10.4.0-centos6-x86_64-server.rpm                                                                                                          | 129 MB     00:08
(5/7): galera-25.3.24-1.rhel6.el6.x86_64.rpm                                                                                                             | 8.8 MB     00:00
(6/7): openssl-1.0.1e-57.0.6.el6.x86_64.rpm                                                                                                              | 1.5 MB     00:01
(7/7): zlib-1.2.3-29.el6.x86_64.rpm                                                                                                                      |  72 kB     00:00
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                            10 MB/s | 200 MB     00:20
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-oracle
Importing GPG key 0xEC551F03:
 Userid : Oracle OSS group (Open Source Software group) <build@oss.oracle.com>
 Package: 6:oraclelinux-release-6Server-2.0.2.x86_64 (@anaconda-OracleLinuxServer-201112121319.x86_64/6.2)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-oracle
Is this ok [y/N]: y
warning: rpmts_HdrFromFdno: Header V4 DSA/SHA1 Signature, key ID 1bb943db: NOKEY
Retrieving key from https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
Importing GPG key 0x1BB943DB:
 Userid: "MariaDB Package Signing Key <package-signing-key@mariadb.org>"
 From  : https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : zlib-1.2.3-29.el6.x86_64                                                                                                                                    1/12
  Updating   : openssl-1.0.1e-57.0.6.el6.x86_64                                                                                                                            2/12
  Installing : MariaDB-common-10.4.0-1.el6.x86_64                                                                                                                          3/12
  Installing : MariaDB-compat-10.4.0-1.el6.x86_64                                                                                                                          4/12
  Installing : MariaDB-client-10.4.0-1.el6.x86_64                                                                                                                          5/12
  Installing : galera-25.3.24-1.rhel6.el6.x86_64                                                                                                                           6/12
Error in PREIN scriptlet in rpm package MariaDB-server-10.4.0-1.el6.x86_64

******************************************************************
A MySQL or MariaDB server package (mysql-server-5.1.52-1.el6_0.1.x86_64) is installed.

The current MariaDB server package is provided by a different
vendor (Oracle America) than MariaDB Foundation.  Some files may be installed
to different locations, including log files and the service
startup script in /etc/init.d/.

Upgrading directly from MySQL 5.1 to MariaDB 10.4 may not
be safe in all cases.  A manual dump and restore using mysqldump is
recommended.  It is important to review the MariaDB manual's Upgrading
section for version-specific incompatibilities.

A manual upgrade is required.

- Ensure that you have a complete, working backup of your data and my.cnf
  files
- Shut down the MySQL server cleanly
- Remove the existing MySQL packages.  Usually this command will
  list the packages you should remove:
  rpm -qa | grep -i '^mysql-'

  You may choose to use 'rpm --nodeps -ev <package-name>' to remove
  the package which contains the mysqlclient shared library.  The
  library will be reinstalled by the MariaDB-shared package.
- Install the new MariaDB packages supplied by MariaDB Foundation
- Ensure that the MariaDB server is started
- Run the 'mysql_upgrade' program

This is a brief description of the upgrade process.  Important details
can be found in the MariaDB manual, in the Upgrading section.
******************************************************************
error: %pre(MariaDB-server-10.4.0-1.el6.x86_64) scriptlet failed, exit status 1
error:   install: %pre scriptlet failed (2), skipping MariaDB-server-10.4.0-1.el6
  Erasing    : mysql-5.1.52-1.el6_0.1.x86_64                                                                                                                               8/12
  Erasing    : mysql-libs-5.1.52-1.el6_0.1.x86_64                                                                                                                          9/12
  Cleanup    : openssl-1.0.0-20.el6.x86_64                                                                                                                                10/12
  Cleanup    : zlib-1.2.3-27.el6.x86_64                                                                                                                                   11/12
mysql-server-5.1.52-1.el6_0.1.x86_64 was supposed to be removed but is not!

Installed:
  MariaDB-client.x86_64 0:10.4.0-1.el6                                                   MariaDB-compat.x86_64 0:10.4.0-1.el6

Dependency Installed:
  MariaDB-common.x86_64 0:10.4.0-1.el6                                                    galera.x86_64 0:25.3.24-1.rhel6.el6

Dependency Updated:
  openssl.x86_64 0:1.0.1e-57.0.6.el6                                                         zlib.x86_64 0:1.2.3-29.el6

Replaced:
  mysql.x86_64 0:5.1.52-1.el6_0.1                                                      mysql-libs.x86_64 0:5.1.52-1.el6_0.1

Failed:
  MariaDB-server.x86_64 0:10.4.0-1.el6                                                  mysql-server.x86_64 0:5.1.52-1.el6_0.1

Complete!
[root@mariadb01 yum.repos.d]#

Comments

Comments loading...
Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.