Comments - unable to START MySQL server at BOOT "systemctl enable mysqld.service" does not work

9 years ago Elena Stepanova

I see that you have already found the corresponding Fedora bug#1014311, and even left a comment there, but apparently you did not read the previous 21 comments. Please do; not only do they answer your question there "Is this a known issue?", but also explain in detail what the reason of the issue is.

9 years ago Asif Cyberdome

Actually, I did real all the comments on that BUG report page. Please, understand I am completely NEW to this. So, the information was completely jibberish to me. I did not understand what they were talking about. I am sorry about that.

I did see that they said something about symbolic links. and tried copying the file into a specific directory. The mysqld.service file or think the mariadb.service. I just realized recently that Fedora has departed with MYSQL and teamed up with MariaDB. I am doing my best to learn. I just re-read all the comments in that page. So, far I did notice someone tried to run the command,

"systemctl enable mariadb.service" and that has worked from them. I will try that command my server and see what happens. It has something to do with Symbolic links. and the mysqld.service is a symbolic link. So, it makes sense to use mariadb.service command.

Migrating from MySQL to MariaDB has caused few issues. But I think we can get through it. At leaset, for being completely NEW to this, At least, I did my research. I have some people who just blindly post on Linux forums for their work assignments and without doing any work?

Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.