To compile OQGraph v2 you need to have the boost library with the versions not earlier than 1.40 and not later than 1.55 and gcc version not earlier than 4.5.

MariaDB starting with 10.0.7

OQGraph v3 compiles fine with the newer boost libraries, but it additionally needs Judy library installed.

When all build prerequisites are met, OQGraph is enabled and compiled automatically. To enable or disable OQGraph explicitly, see the generic plugin build instructions.

Finding out why OQGRAPH didn't compile

If OQGRAPH gets compiled properly, there should be a file like:

storage/oqgraph/ha_oqgraph.so

If this is not the case, then you can find out if there is any modules missing that are required by OQGRAPH by doing:

cmake . -LAH | grep -i oqgraph

Comments

Comments loading...
Loading