The most recent release in the MariaDB 5.5 series is:
MariaDB 5.5.57 Download Now

Download | Release Notes | Changelog | Overview of 5.5

Release date: 23 May 2013

This is a Stable (GA) release. In general this means that there are no known serious bugs, except for those marked as feature requests, that no bugs were fixed since last release that caused a notable code changes, and that we believe the code is ready for general usage (based on bug inflow).

For a description of MariaDB 5.5 see the What is MariaDB 5.5? page.

For a list of changes made in this release, with links to detailed information on each push, see the MariaDB 5.5.31 Changelog.

In most respects MariaDB will work exactly as MySQL: all commands, interfaces, libraries and APIs that exist in MySQL also exist in MariaDB.

This is primarily a bug-fix release.

Includes MariaDB 5.3.12 and MySQL 5.5.31

This release includes MariaDB 5.3.12 and MySQL 5.5.31. See Changes in MySQL 5.5.31 for what changed in MySQL.

Security fixes

This release includes fixes for the following security vulnerabilities:

Other Notable Updates

  • Includes XtraDB from Percona Server-5.5.30-rel30.2
  • Includes an alpha version of the QUERY_CACHE_INFO plugin, that allows to see the content of the query cache via the corresponding INFORMATION_SCHEMA table.
  • MariaDB MSI packages for Windows include the latest HeidiSQL 8.0.

Ubuntu 13.04 "Raring" Packages

Packages are now available for Ubuntu 13.04 "Raring". Use the repository configuration tool to get the appropriate commands.

Ubuntu 8.04 LTS "Hardy" and 11.10 "Oneiric" Deprecated

In accordance with the MariaDB Deprecation Policy the following distributions have reached the end of their support periods (EOL):

  • Ubuntu 8.04 LTS "Hardy"
  • Ubuntu 11.10 "Oneiric"
  • Mint 9 LTS "Isadora"
  • Mint 12 "Lisa"

This release (MariaDB 5.5.31) is therefore the last MariaDB release to feature packages for these distros. The repositories for them will remain online until the 5.5.32 release. At that time they will go away.

Binary tar.gz files built on Ubuntu "Hardy" will also be going away. These are the ones that do not require GLIBC_2.14+. So for the next release, all binary tar.gz files for Linux will require GLIBC_2.14+.

Thanks, and enjoy MariaDB!


Be notified of new releases automatically by subscribing to the announce 'at' mariadb.org announcement list (this is a low traffic, announce-only list).

MariaDB may already be included in your favorite OS distribution. More information can be found on the Distributions which Include MariaDB page.

Comments

Comments loading...