MariaDB 5.5, Ubuntu LTS, Rails and required libmysqlclient-dev


I posted a question on Ubuntu regarding this but it may be to specific for them to answer and thought someone here may have greater expertise. Refer

I want to use MariaDB in my rails application and I am using Ubuntu 12.04.3. I have successfully installed MariaDB using the materials at the MariaDB Downloads page and installed the repositories.

A requirement in Rails for connectivity is the mysql2 gem. In order to have this compile the libmysqlclient-dev package is needed to be installed.

However after installing Maria I attempted to instal this requirement but could not meed dependency and Ubuntu returned.

Has anyone had this and know how to work around it?

sayth@sayth-TravelMate-5740G:$ sudo apt-get install libmysqlclient-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies. libmysqlclient-dev : Depends: libmysqlclient18 (= 5.5.32-0ubuntu0.12.04.1) but 5.5.32+maria-1precise is to be installed E: Unable to correct problems, you have held broken packages. sayth@sayth-TravelMate-5740G:$

Answer Answered by Ian Gilfillan in this comment.

Your query seems to be addressed at Installing MariaDB .deb Files


Comments loading...
Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.