Hello,

I've been using MariaDB successfully on Ubuntu 10.04 LTS for awhile now.

I went to do the usual apt-get update ; apt-get -fmuy dist-upgrade and was surprised to see this:

Preparing to replace libmysqlclient16 5.1.49-mariadb82 (using .../libmysqlclient16_5.1.61-0ubuntu0.10.04.1_amd64.deb) ...
Unpacking replacement libmysqlclient16 ...
dpkg: error processing /var/cache/apt/archives/libmysqlclient16_5.1.61-0ubuntu0.10.04.1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libmysqlclient.so.16.0.0', which is also in package libmariadbclient16 0:5.1.49-mariadb82
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libmysqlclient16_5.1.61-0ubuntu0.10.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried to remove libmysqlclient16 but it wants to remove other libs that I need including libdbd-mysql-perl and libmariadbclient16.

Did something change recently that would cause this conflict? I'm not using 11.10 server since it's not eligible for Long Term Support.

Thanks!

Answer Answered by dbart in this comment.

This is caused by a recent security update for Ubuntu's MySQL packages.

From the output, apt is trying to install the Ubuntu MySQL libmysqlclient 5.1.61 package and failing because it is erroneously seeing that package as an update for the MariaDB 5.1.49 libmysqlclient package (which it is not).

The latest release in the MariaDB 5.1 series is 5.1.60, so even updating to that won't help because the MySQL version in Ubuntu's repository is now at version 5.1.61. But if you upgrade to MariaDB 5.2 or 5.3 the error will go away because apt won't see a MySQL 5.1.61 update as belonging to MariaDB 5.2.x.

I've updated several servers from MariaDB and MySQL 5.1.x to MariaDB 5.2.x and 5.3.x and never had any trouble.

Comments

Comments loading...