Hi,

I am running MariaDB 5.3 and want to upgrade to 5.5 latest. I changed my sources list to the 5.5 repository per the instructions, ran an apt-get update and then apt-get dist-upgrade. The mariadb-server package is being held back. Below is the output. Not sure why. Any hints on upgrading?

Thanks, Terry

>apt-get -s dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  libmariadbclient18 libmysqlclient18 mariadb-common
The following packages have been kept back:
  mariadb-server
The following packages will be upgraded:
  mysql-common
1 upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Inst mysql-common [5.3.7-mariadb116~squeeze] (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [all]) [mariadb-server-5.3:i386 on mariadb-common:i386] [libmariadbclient16:i386 mariadb-server-5.3:i386 mariadb-client-core-5.3:i386 mariadb-client-5.3:i386 ]
Inst mariadb-common (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [all])
Inst libmysqlclient18 (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [i386]) []
Inst libmariadbclient18 (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [i386])
Conf mysql-common (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [all])
Conf mariadb-common (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [all])
Conf libmariadbclient18 (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [i386])
Conf libmysqlclient18 (5.5.24-mariadb1~squeeze MariaDB:ftp.osuosl.org [i386])

Answer Answered by terryr in this comment.

I did perform an apt-get upgrade (see message above) and I did try an update with the same results. The only pinning I had was mysql-common to origin ftp.osuosl.org as this package was conflicting with dotdeb.org.

I've done quite a bit more research and found that libmysqlclient18 was conflicting with dotdeb.org as well. I don't know why these conflicts are happening with dotdeb.org and I don't know enough about apt to begin to hazard a guess.

I ended up trying to install on a fresh install of debian and got it to work there but I could not install it using mariadb-server. I had to specify mariadb-server-5.5.

So on my production server, I removed the package mariadb-server and pinned the mariadb repository higher than dotdeb and was able to upgrade to 5.5 without a problem.

Comments

Comments loading...