MariaDB Deprecation Policy

Il progetto MariaDB cerca di supportare il maggior numero possibile di sistemi operativi e distribuzioni Linux. Tuttavia, quando un OS cessa di ricevere aggiornamenti di sicurezza e di altro genere, per il progetto MariaDB diventa difficile fornire pacchetti per quella piattaforma. In questi casi, la nostra politica è di deprecare la piattaforma e smettere di fornire pacchetti binari specifici.

Piattaforme correnti per i pacchetti

Il progetto MariaDB fornisce pacchetti per i seguenti sistemi operativi e distribuzioni Linux:

PlatformPlanned Deprecation Date
Red Hat Enterprise Linux 7.4Ago 2019
CentOS 7.4Ago 2019
openSUSE 15.0Nov 2019
Windows Server 2008Gen 2020
Windows Server 2008 R2Gen 2020
Windows 7Gen 2020
Debian 8 "Jessie"Giu 2020
Red Hat Enterprise Linux 6.xNov 2020
CentOS 6.xNov 2020
Ubuntu 16.04 LTS "Xenial"Apr 2021
Mint 18 LTS "Serena"Apr 2021
Ubuntu 16.04 LTS "Xenial"Apr 2021
Mint 18 LTS "Serena"Apr 2021
Debian 9 "Stretch"Giu 2022
Windows 8.1Gen 2023
Ubuntu 18.04 "Bionic"Apr 2023
Windows Server 2012 R2Ott 2023
Red Hat Enterprise Linux 7.xGiu 2024
CentOS 7.xGiu 2024
SLES 12.xOtt 2024
SLES 15.xLug 2028
Fedora 291 mese dopo Fedora 31
Fedora 301 mese dopo Fedora 32
SLES 15.06 mese dopo SLES 12.1
Arch LinuxRolling release
MageiaRolling release

Piattaforme deprecate

Il progetto MariaDB non fornisce più i pacchetti per i seguenti sistemi operativi e distribuzioni Linux:

PlatformDeprecation Date
openSUSE 42.3Giu 2019
Ubuntu 18.10 "Cosmic"Lug 2019
Fedora 28Mag 2019
Ubuntu 14.04 LTS "Trusty"Apr 2019
Mint 17.1 LTS "Rebecca"Apr 2019
Mint 17 LTS "Qiana"Apr 2019
SLES 11.4Mar 2019
Fedora 27Nov 2018
Ubuntu 17.10 "Artful"Lug 2018
Fedora 26Mag 2018
Debian 7 "Wheezy"Mag 2018
Fedora 25Feb 2018
Ubuntu 17.04 "Zesty"Gen 2018
openSUSE 42.2Gen 2018
Red Hat Enterprise Linux 7.2Nov 2017
CentOS 7.2Nov 2017
Fedora 24Ago 2017
Ubuntu 16.10 "Yakkety"Lug 2017
Ubuntu 12.04 LTS "Precise"Apr 2017
Mint 13 LTS "Maya"Apr 2017
Red Hat Enterprise Linux 7.4Ago 2019
CentOS 7.4Ago 2019
Red Hat Enterprise Linux 5Mar 2017
CentOS 5Mar 2017
Fedora 23Feb 2017
openSUSE 13Gen 2017
Fedora 22Ago 2016
Ubuntu 15.10 "Wily"Lug 2016
Windows 2003 ServerApr 2016
Windows XP+Apr 2016
Debian 6 "Squeeze"Feb 2016
Ubuntu 15.04 "Raring"Gen 2016
Fedora 21Dic 2015
Fedora 20Ott 2015
Ubuntu 14.10 "Utopic"Lug 2015
Ubuntu 10.04 LTS "Lucid"Apr 2015
Mint 9 LTS "Isadora"Apr 2015
Fedora 19Apr 2015
FreeBSD 9.2Sep 2014
Ubuntu 13.10 "Saucy"Lug 2014
Mint 16 "Petra"Lug 2014
Ubuntu 12.10 "Quantal"Apr 2014
Mint 14 "Nadia"Apr 2014
Ubuntu 13.04 "Raring"Gen 2014
Mint 15 "Olivia"Gen 2014
Fedora 18 "Spherical Cow"Dic 2013
Fedora 17 "Beefy Miracle"Ago 2013
Ubuntu 8.04 LTS "Hardy"Apr 2013
Ubuntu 11.10 "Oneiric"Apr 2013
Mint 9 LTS "Isadora"Apr 2013
Mint 12 "Lisa"Apr 2013
Fedora 16 "Verne"Feb 2013
Ubuntu 10.10 "Maverick"Gen 2013
Ubuntu 11.04 "Natty"Gen 2013
Debian 5 "Lenny"Gen 2013
Debian 4 "Etch"
Ubuntu 8.10 "Intrepid"
Ubuntu 9.04 "Jaunty"
Ubuntu 9.10 "Karmic"

Supporto per le piattaforme deprecate

Se si utilizza un sistema operativo o una distribuzione Linux deprecata, i pacchetti e il supporto non sono completamente introvabili. Società come SkySQL e Monty Program forniscono supporto per tutte le versioni di MariaDB, fino a versioni molto vecchie di MySQL. Questo include anche i pacchetti binari. Contattateli per ulteriori dettagli.

Commenti

Sto caricando i commenti......
Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.