mariadb_es_repo_setup for MariaDB Enterprise Server 10.5

Overview

The mariadb_es_repo_setup script configures APT/YUM/ZYpp to install software from the MariaDB Enterprise Server repository on supported Linux operating systems.

It requires a Customer Download Token, which is set using the --token option.

Note

To configure APT/YUM/ZYpp to install software from the MariaDB Community Server repository, see mariadb_repo_setup instead.

Installation

The mariadb_es_repo_setup script is available for download from MariaDB Corporation:

Additional information on its use is available in the Deployment Guide.

mariadb_es_repo_setup Options for MariaDB Enterprise Server 10.5

Option

Description

--apply

Write OS's repository configuration files. This will also import GPG keys and update the package cache on platforms where that behavior exists.

--help

Display this help and exit.

--include-unsupported

Include the 'Unsupported' repository.

--mariadb-maxscale-version

Override the default MariaDB MaxScale version. By default, the script will use 'latest'.

--mariadb-server-version

Override the default MariaDB Server version. By default, the script will use '10.6'.

--os-type

Override detection of OS type. Acceptable values include 'debian', 'ubuntu', 'rhel', and 'sles'.

--os-version

Override detection of OS version. Acceptable values depend on the OS type you specify.

--skip-check-installed

Skip tests for required prerequisites for this script.

--skip-key-import

Skip importing GPG signing keys.

--skip-maxscale

Skip the 'MaxScale' repository.

--skip-server

Skip the 'MariaDB Server' repository.

--skip-tools

Skip the 'Tools' repository.

--skip-xpand

Skip the 'Xpand' instructions. RHEL/CentOS 7 only.

--token

Your MariaDB Enterprise repository token (required).

--verbose

Display [info] messages.

--version

Output the script version and exit.

To see options supported in other versions, see "mariadb_es_repo_setup Options by MariaDB Server Version".