ed25519 Plugin

Overview

Authentication plugin, validates against a password hash encrypted using EDCDSA. It is installed and enabled by default for MariaDB Enterprise Server, but it cannot be used to authenticate in MariaDB SkySQL, because MaxScale 2.5 does not support ed25519.

See also: Plugins in 10.6 ES, in 10.5 ES, and in 10.4 ES

DETAILS

PARAMETERS

Type

AUTHENTICATION

Maturity

Stable

Version

1.1

Auth Version

1.1

SKYSQL

Cloud

SkySQL Topology

ES Ver

Plugin Present?

AWS

Replicated Transactions

10.4

Yes

10.5

Yes

10.6

Yes

Single Node Transactions

10.4

Yes

10.5

Yes

10.6

Yes

GCP

Multi-Node Analytics

10.5

No

Single Node Analytics

10.5

No

Replicated Transactions

10.4

Yes

10.5

Yes

10.6

Yes

Single Node Transactions

10.4

Yes

10.5

Yes

10.6

Yes

CHANGE HISTORY

Release Series

History

10.6 Enterprise

  • Present starting in MariaDB Enterprise Server 10.6.4-1.

10.5 Enterprise

  • Present starting in MariaDB Enterprise Server 10.5.3-1.

10.4 Enterprise

  • Present starting in MariaDB Enterprise Server 10.4.6-1.

EXTERNAL REFERENCES