I'm new to maria, coming from mysql, and I'm trying to run the mysql_install_db program to create the new databases. This is what i'm executing as root: /usr/bin/mysql_install_db --user=mysql --datadir=/var/lib/mysql --basedir=/usr --force I've tried it with and without the force option. I always get the same error: ERROR: 1005 Can't create table `mysql`.`innodb_table_stats` (errno: 165 "Table is read only") 160114 11:35:10 [ERROR] Aborting

Any help will be greatly appreciated.

Answer Answered by Steven Kuns in this comment.

Thanks for the help... i got fed up with trying to guess what was causing it. it was a yum install by a coworker. I removed the packages and reinstall with the binaries. What worked fine. Thanks for the suggestions... I think it had to do with the my.cnf that was created with the yum. Thanks for all the help...


Comments loading...
Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.