Crash when inserting or selecting large amounts of text in/from LongText field

Update: This appears to only happen on Windows/Ubuntu 16. It seems very particular to my set-up. I set up an ec2 instance that is nearly identical to my local set-up and all is well.

Hello, I'm running 10.0 on a production server and recently installed 10.2 on a local server. Longtext fields (utf8mb4_unicode_ci) with content over approximately 300k characters cause MariaDB to lock-up. The same field on 10.0 is ok.

My primary set up is Ubuntu 16 on Windows Creator Edition. 32gigs of RAM. I've tried various things with my.cnf and reinstalled several times but the problem persists.

I've also tried on a CENTOS server and it appears to be an issue there as well. I hesitate to says it's definitely a problem there because I didn't test extensively. It's possible the data I was using is corrupt.

I've located the offending rows and they don't seem to be corrupt though I admit that would be tough to tell just by looking. I've managed to open the contents of the offending rows in text editors and though they do slow the application down, they do open and are editable.

The error log is empty and database locks up indefinitely. It seems to a memory issue, but the task manager doesn't show any spikes.

I want to use some of the new features in 10.2 but hesitate because of this issue.

Any ideas of what I might be doing wrong? Or how to really identify the issue?

Thank you.

Answer Answered by Ian Gilfillan in this comment.

I suggest reporting as a bug and with the assistance there attempt to create a repeatable test case.


Comments loading...
Content reproduced on this site is the property of its respective owners, and this content is not reviewed in advance by MariaDB. The views, information and opinions expressed by this content do not necessarily represent those of MariaDB or any other party.