mariadb_es_repo_setup

Overview

The mariadb_es_repo_setup script configures APT/YUM/ZYpp to install software from the MariaDB Enterprise Repository on supported Linux operating systems.

To configure APT/YUM/ZYpp to install software from the MariaDB Community Repository, see mariadb_repo_setup instead.

Installation

The mariadb_es_repo_setup script is available for download from MariaDB Corporation:

$ wget https://dlm.mariadb.com/enterprise-release-helpers/mariadb_es_repo_setup

$ echo "3f4a9d1c507a846a598e95d6223871aade69a9955276455324e7cc5f54a87021  mariadb_es_repo_setup" \
       | sha256sum -c -

$ chmod +x mariadb_es_repo_setup

Customer Download Token

The mariadb_es_repo_setup script requires a Customer Download Token, which is set using the --token option:

$ sudo ./mariadb_es_repo_setup --token="CUSTOMER_DOWNLOAD_TOKEN" --apply

Releases

For information on releases, see "Release Notes for mariadb_es_repo_setup".

Usage

$ sudo ./mariadb_es_repo_setup [ OPTIONS .. ]

For additional information, see "Configure the MariaDB Enterprise Repository".

mariadb_es_repo_setup Options

Option

Description

--apply

Write OS's repository configuration files. This will also import GPG keys and update the package cache on platforms where that behavior exists.

--arch

Override detection of CPU architecture. Acceptable values are 'x86_64', 'aarch64', 'amd64', & 'arm64'.

--help

Display this help and exit.

--include-unsupported

Include the 'Unsupported' repository.

--mariadb-enterprise-tools-version

Override the default MariaDB Enterprise Tools version. By default, the script will use 'latest'.

--mariadb-maxscale-version

Override the default MariaDB MaxScale version. By default, the script will use 'latest'.

--mariadb-server-version

Override the default MariaDB Server version. By default, the script will use '10.6'.

--os-type

Override detection of OS type. Acceptable values include 'debian', 'ubuntu', 'rhel', and 'sles'.

--os-version

Override detection of OS version. Acceptable values depend on the OS type you specify.

--skip-check-installed

Skip tests for required prerequisites.

--skip-enterprise-tools

Skip the 'Enterprise Tools' repository

--skip-key-import

Skip importing GPG signing keys.

--skip-maxscale

Skip the 'MaxScale' repository.

--skip-server

Skip the 'MariaDB Enterprise Server' repository.

--skip-tools

Skip the 'Tools' repository.

--skip-verify

Skip verification of MariaDB Server versions. Use with caution as this can lead to an invalid repository configuration file being created.

--skip-xpand

Skip the 'Xpand' instructions. RHEL/CentOS 7 only.

--token

Your Customer Download Token (required). Use the MariaDB Customer Portal to find your token.

--verbose

Display [info] messages.

--version

Output the script version and exit.